gtetrinet-0.7.11-r3.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. GCONF_DEBUG="yes"
  5. GNOME_TARBALL_SUFFIX="bz2"
  6. inherit autotools eutils gnome2
  7. DESCRIPTION="Tetrinet Clone for GNOME"
  8. HOMEPAGE="http://gtetrinet.sourceforge.net/"
  9. SRC_URI="${SRC_URI}
  10. mirror://gentoo/gtetrinet-gentoo-theme-0.1.tbz2"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="amd64 ppc x86"
  14. IUSE="nls ipv6"
  15. RDEPEND="
  16. dev-libs/libxml2
  17. media-libs/libcanberra
  18. >=gnome-base/gconf-2
  19. >=gnome-base/libgnome-2
  20. >=gnome-base/libgnomeui-2
  21. nls? ( virtual/libintl )
  22. "
  23. DEPEND="${RDEPEND}
  24. virtual/pkgconfig
  25. nls? ( sys-devel/gettext )
  26. "
  27. src_prepare() {
  28. epatch "${FILESDIR}"/${P}-noesd.patch
  29. epatch "${FILESDIR}"/${P}-desktopfile.patch
  30. epatch "${FILESDIR}"/${P}-format-security.patch
  31. sed -i \
  32. -e "/^pkgdatadir =/s:=.*:= ${GAMES_DATADIR}/${PN}:" \
  33. src/Makefile.in themes/*/Makefile.in || die
  34. sed -i \
  35. -e '/^gamesdir/s:=.*:=@bindir@:' \
  36. src/Makefile.am || die
  37. rm -rf "${WORKDIR}"/gentoo/.xvpics || die # Remove cruft
  38. eautoreconf
  39. gnome2_src_prepare
  40. }
  41. src_configure() {
  42. gnome2_src_configure \
  43. $(use_enable ipv6)
  44. }
  45. src_install() {
  46. gnome2_src_install
  47. mv "${WORKDIR}"/gentoo "${ED}/usr/share/${PN}/themes/" || die
  48. }