ltris-1.0.19.ebuild 853 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools flag-o-matic eutils games
  5. DESCRIPTION="very polished Tetris clone"
  6. HOMEPAGE="http://lgames.sourceforge.net/index.php?project=LTris"
  7. SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE="nls"
  12. RDEPEND="media-libs/libsdl[video]
  13. media-libs/sdl-mixer
  14. nls? ( virtual/libintl )"
  15. DEPEND="${RDEPEND}
  16. nls? ( sys-devel/gettext )"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-gentoo.patch
  19. mv configure.in configure.ac || die
  20. AT_M4DIR=m4 eautoreconf
  21. append-cflags -std=gnu89 # build with gcc5 (bug #570966)
  22. }
  23. src_configure() {
  24. egamesconf $(use_enable nls)
  25. }
  26. src_install() {
  27. default
  28. newicon icons/ltris48.xpm ${PN}.xpm
  29. make_desktop_entry ltris LTris
  30. prepgamesdirs
  31. }