textmaze-1.2.ebuild 614 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit games
  5. MY_P=${PN}_v${PV}
  6. DESCRIPTION="An ncurses-based maze solving game written in Perl"
  7. HOMEPAGE="http://robobunny.com/projects/textmaze/html/"
  8. SRC_URI="http://www.robobunny.com/projects/${PN}/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~ppc x86"
  12. IUSE=""
  13. RDEPEND="dev-perl/Curses"
  14. S=${WORKDIR}/TextMaze
  15. src_prepare() {
  16. sed -i \
  17. -e "s#/usr/local/bin/perl#/usr/bin/perl#" \
  18. textmaze || die
  19. }
  20. src_install() {
  21. dogamesbin textmaze
  22. dodoc CHANGES README
  23. prepgamesdirs
  24. }