world-of-goo-demo-1.41-r1.ebuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="A puzzle game with a strong emphasis on physics"
  6. HOMEPAGE="http://2dboy.com/"
  7. if [[ ${PN} == *-demo ]] ; then
  8. MY_PN="WorldOfGooDemo"
  9. SRC_URI="${MY_PN}.${PV}.tar.gz"
  10. else
  11. MY_PN="WorldOfGoo"
  12. SRC_URI="${MY_PN}Setup.${PV}.tar.gz"
  13. fi
  14. LICENSE="2dboy-EULA"
  15. SLOT="0"
  16. KEYWORDS="amd64 x86"
  17. IUSE=""
  18. RESTRICT="fetch strip"
  19. RDEPEND="media-libs/libsdl[sound,opengl,video]
  20. media-libs/sdl-mixer[vorbis]
  21. sys-libs/glibc
  22. virtual/opengl
  23. virtual/glu
  24. >=sys-devel/gcc-3.4"
  25. DEPEND=""
  26. S=${WORKDIR}/${MY_PN}
  27. dir=${GAMES_PREFIX_OPT}/${PN}
  28. QA_PREBUILT="${dir:1}/${MY_PN%Demo}.bin32
  29. ${dir:1}/${MY_PN%Demo}.bin64"
  30. pkg_nofetch() {
  31. if [[ ${PN} == *-demo ]] ; then
  32. elog "To download the demo, visit http://worldofgoo.com/dl2.php?lk=demo"
  33. elog "and download ${A} and place it in ${DISTDIR}"
  34. else
  35. elog "Download ${A} from ${HOMEPAGE} and place it in ${DISTDIR}"
  36. fi
  37. }
  38. src_install() {
  39. exeinto "${dir}"
  40. doexe ${MY_PN%Demo}*
  41. games_make_wrapper ${PN} "${dir}"/${MY_PN%Demo}
  42. insinto "${dir}"
  43. doins -r icons properties res
  44. newicon icons/scalable.svg ${PN}.svg
  45. if [[ ${PN} == *-demo ]] ; then
  46. make_desktop_entry ${PN} "World of Goo (Demo)"
  47. else
  48. make_desktop_entry ${PN} "World of Goo"
  49. fi
  50. dodoc linux-issues.txt
  51. dohtml readme.html
  52. prepgamesdirs
  53. }