dear-esther-20130608.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # TODO: unbundle libSDL2
  4. EAPI=5
  5. inherit eutils gnome2-utils unpacker games
  6. TIMESTAMP="${PV:4:2}${PV:6:2}${PV:0:4}"
  7. DESCRIPTION="Ghost story, told using first-person gaming technologies"
  8. HOMEPAGE="http://dear-esther.com/"
  9. SRC_URI="dearesther-linux-${TIMESTAMP}-bin"
  10. LICENSE="all-rights-reserved"
  11. SLOT="0"
  12. KEYWORDS="-* amd64 x86"
  13. IUSE=""
  14. RESTRICT="bindist fetch splitdebug"
  15. MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
  16. QA_PREBUILT="${MYGAMEDIR#/}/dearesther_linux
  17. ${MYGAMEDIR#/}/bin/*.so*"
  18. DEPEND="app-arch/unzip"
  19. RDEPEND="
  20. >=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
  21. >=media-libs/libsdl-1.2.15-r5[abi_x86_32(-)]
  22. >=media-libs/openal-1.15.1[abi_x86_32(-)]
  23. x11-libs/libX11[abi_x86_32(-)]
  24. virtual/opengl[abi_x86_32(-)]"
  25. S=${WORKDIR}/data
  26. pkg_nofetch() {
  27. einfo "Please buy & download ${SRC_URI} from:"
  28. einfo " ${HOMEPAGE}"
  29. einfo "and move it to ${DISTDIR}"
  30. einfo
  31. }
  32. src_unpack() {
  33. unpack_zip ${A}
  34. }
  35. src_install() {
  36. insinto "${MYGAMEDIR}"
  37. doins -r bin dearesther platform dearesther_linux
  38. doicon -s 256 dearesther.png
  39. make_desktop_entry "${PN}" "Dear Esther" dearesther
  40. games_make_wrapper ${PN} "./dearesther_linux -game dearesther" "${MYGAMEDIR}" "${MYGAMEDIR}/bin"
  41. dodoc README-linux.txt
  42. fperms +x "${MYGAMEDIR}"/dearesther_linux
  43. prepgamesdirs
  44. }
  45. pkg_preinst() {
  46. games_pkg_preinst
  47. gnome2_icon_savelist
  48. }
  49. pkg_postinst() {
  50. games_pkg_postinst
  51. gnome2_icon_cache_update
  52. }
  53. pkg_postrm() {
  54. gnome2_icon_cache_update
  55. }