eternal-lands-bloodsucker-3.0.ebuild 795 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit eutils games
  5. DESCRIPTION="Non-official map pack for Eternal Lands"
  6. HOMEPAGE="http://maps.el-pl.org/"
  7. SRC_URI="mirror://gentoo/${P}.zip"
  8. LICENSE="CC-BY-NC-SA-3.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~x86-fbsd"
  11. IUSE=""
  12. DEPEND="games-rpg/eternal-lands-data[bloodsuckermaps]"
  13. RDEPEND="${DEPEND}"
  14. S="${WORKDIR}"
  15. src_install() {
  16. insopts -m 0660
  17. insinto "${GAMES_DATADIR}/eternal-lands"
  18. doins -r maps || die "doins failed"
  19. prepgamesdirs
  20. }
  21. pkg_postinst() {
  22. games_pkg_postinst
  23. elog "Note that the Bloodsucker Maps are not official maps and are not"
  24. elog "supported by the Eternal Lands team."
  25. elog "Please do not bother Eternal Lands staff about bugs with the maps."
  26. }