catcodec-1.0.3.ebuild 619 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Decodes and encodes sample catalogues for OpenTTD"
  6. HOMEPAGE="http://www.openttd.org/en/download-catcodec"
  7. SRC_URI="http://binaries.openttd.org/extra/catcodec/${PV}/${P}-source.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ppc ppc64 x86"
  11. IUSE=""
  12. src_prepare() {
  13. tc-export CXX
  14. epatch "${FILESDIR}"/${P}-gcc47.patch
  15. }
  16. src_compile() {
  17. emake VERBOSE=1
  18. }
  19. src_install() {
  20. dobin catcodec
  21. dodoc changelog.txt docs/readme.txt
  22. doman docs/catcodec.1
  23. }