deutex-4.4.0.ebuild 650 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs eutils
  5. DESCRIPTION="A wad composer for Doom, Heretic, Hexen and Strife"
  6. HOMEPAGE="http://www.teaser.fr/~amajorel/deutex/"
  7. SRC_URI="http://www.teaser.fr/~amajorel/deutex/${P}.tar.gz"
  8. LICENSE="GPL-2+ LGPL-2+ HPND"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. RDEPEND=""
  13. DEPEND=""
  14. src_prepare() {
  15. epatch \
  16. "${FILESDIR}"/${P}-makefile.patch \
  17. "${FILESDIR}"/${P}-64bit.patch \
  18. "${FILESDIR}"/${P}-ovflfix.patch
  19. tc-export CC
  20. }
  21. src_install() {
  22. dobin deusf deutex
  23. doman deutex.6
  24. dodoc CHANGES README TODO
  25. }