lgogdownloader-3.2.ebuild 617 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="Unofficial GOG.com downloader for Linux"
  6. HOMEPAGE="https://sites.google.com/site/gogdownloader/"
  7. SRC_URI="https://sites.google.com/site/gogdownloader/${P}.tar.gz"
  8. LICENSE="WTFPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="+debug"
  12. RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
  13. dev-cpp/htmlcxx:0=
  14. dev-libs/boost:0=
  15. >=dev-libs/jsoncpp-1.7:0=
  16. dev-libs/tinyxml2:0=
  17. net-libs/liboauth:0=
  18. >=net-misc/curl-7.32:0=[ssl]"
  19. DEPEND="${RDEPEND}
  20. sys-apps/help2man
  21. virtual/pkgconfig"