mcrcon-0.0.5.ebuild 584 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs games
  5. DESCRIPTION="Remote connection client for Minecraft servers"
  6. HOMEPAGE="https://sourceforge.net/projects/mcrcon/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
  8. LICENSE="ZLIB"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. S="${WORKDIR}"
  13. src_compile() {
  14. # Flags taken from COMPILING.txt.
  15. $(tc-getCC) ${CFLAGS} ${LDFLAGS} -std=gnu11 -pedantic -Wall -Wextra -o "${PN}" "${PN}.c" || die
  16. }
  17. src_install() {
  18. dogamesbin "${PN}"
  19. dodoc README.txt
  20. }