vispatch-1.4.6.ebuild 508 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="WaterVIS utility for glquake"
  6. HOMEPAGE="http://vispatch.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/vispatch/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. S=${WORKDIR}/${P}/source
  13. src_prepare() {
  14. sed -i \
  15. -e '/^CFLAGS/d' \
  16. -e '/^LDFLAGS/d' \
  17. makefile || die
  18. tc-export CC
  19. }
  20. src_install() {
  21. dobin ${PN}
  22. dodoc ${PN}.txt
  23. }