wit-2.31a.ebuild 861 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="A set of command line tools to manipulate Wii/GameCube ISO images and WBFS containers"
  6. HOMEPAGE="http://wit.wiimm.de/"
  7. SRC_URI="https://dev.gentoo.org/~radhermit/distfiles/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="+fuse +zlib"
  12. RDEPEND="
  13. app-arch/bzip2
  14. fuse? ( sys-fs/fuse )
  15. zlib? ( sys-libs/zlib )
  16. "
  17. DEPEND="${RDEPEND}"
  18. DOCS="doc/*.txt"
  19. src_prepare() {
  20. epatch "${FILESDIR}"/${PN}-2.30a-makefile.patch
  21. epatch "${FILESDIR}"/${PN}-2.30a-no-exec-stack.patch
  22. epatch "${FILESDIR}"/${PN}-2.30a-sizeof-pointer-memaccess.patch
  23. }
  24. src_compile() {
  25. export NO_FUSE=$(usex fuse 0 1)
  26. export NO_ZLIB=$(usex zlib 0 1)
  27. emake INSTALL_PATH="${D}"/usr CC="$(tc-getCC)"
  28. emake doc
  29. }