dconf-0.26.0-r1.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2 bash-completion-r1 virtualx
  5. DESCRIPTION="Simple low-level configuration system"
  6. HOMEPAGE="https://wiki.gnome.org/action/show/Projects/dconf"
  7. LICENSE="LGPL-2.1+"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~arm-linux ~x86-linux"
  10. IUSE=""
  11. RDEPEND="
  12. >=dev-libs/glib-2.44.0:2
  13. sys-apps/dbus
  14. "
  15. DEPEND="${RDEPEND}
  16. app-text/docbook-xml-dtd:4.2
  17. app-text/docbook-xsl-stylesheets
  18. dev-libs/libxslt
  19. dev-util/gdbus-codegen
  20. >=dev-util/gtk-doc-am-1.15
  21. sys-devel/gettext
  22. virtual/pkgconfig
  23. "
  24. src_configure() {
  25. gnome2_src_configure \
  26. --disable-gcov \
  27. --enable-man \
  28. VALAC=$(type -P true)
  29. }
  30. src_test() {
  31. virtx emake check
  32. }
  33. src_install() {
  34. gnome2_src_install
  35. # GSettings backend may be one of: memory, gconf, dconf
  36. # Only dconf is really considered functional by upstream
  37. # must have it enabled over gconf if both are installed
  38. echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
  39. echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
  40. doenvd 51dconf
  41. }
  42. pkg_postinst() {
  43. gnome2_pkg_postinst
  44. # Kill existing dconf-service processes as recommended by upstream due to
  45. # possible changes in the dconf private dbus API.
  46. # dconf-service will be dbus-activated on next use.
  47. pids=$(pgrep -x dconf-service)
  48. if [[ $? == 0 ]]; then
  49. ebegin "Stopping dconf-service; it will automatically restart on demand"
  50. kill ${pids}
  51. eend $?
  52. fi
  53. }