gnustep-back-xlib-0.25.0.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnustep-base
  5. DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library"
  6. HOMEPAGE="http://www.gnustep.org"
  7. SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
  11. IUSE="opengl xim"
  12. RDEPEND="${GNUSTEP_CORE_DEPEND}
  13. =gnustep-base/gnustep-gui-${PV%.*}*
  14. opengl? ( virtual/opengl virtual/glu )
  15. x11-libs/libICE
  16. x11-libs/libSM
  17. x11-libs/libX11
  18. x11-libs/libXext
  19. x11-libs/libXi
  20. x11-libs/libXmu
  21. x11-libs/libXt
  22. x11-libs/libXft
  23. x11-libs/libXrender
  24. >=media-libs/freetype-2.1.9
  25. !gnustep-base/gnustep-back-art
  26. !gnustep-base/gnustep-back-cairo"
  27. DEPEND="${RDEPEND}"
  28. S=${WORKDIR}/gnustep-back-${PV}
  29. src_configure() {
  30. egnustep_env
  31. myconf="$(use_enable opengl glx)"
  32. myconf="$myconf $(use_enable xim)"
  33. myconf="$myconf --enable-server=x11"
  34. myconf="$myconf --enable-graphics=xlib"
  35. econf $myconf
  36. }