dbuskit-0.1.ebuild 783 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools gnustep-2
  5. DESCRIPTION="framework that interfaces Objective-C applications with the D-Bus IPC service"
  6. HOMEPAGE="http://www.gnustep.org"
  7. SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND=">=sys-apps/dbus-1.2.1"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-configure.patch
  16. # Bug 410697
  17. sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
  18. -i configure.ac || die "ObjectiveC2 runtime sed failed"
  19. if ! use doc; then
  20. # Remove doc target
  21. sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
  22. || die "doc sed failed"
  23. fi
  24. eautoreconf
  25. }