yakuake-3.0.4.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit kde5
  5. DESCRIPTION="Quake-style terminal emulator based on konsole"
  6. HOMEPAGE="http://yakuake.kde.org/"
  7. if [[ ${KDE_BUILD_TYPE} != live ]]; then
  8. SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
  9. fi
  10. LICENSE="GPL-2 LGPL-2"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. DEPEND="
  14. $(add_frameworks_dep karchive)
  15. $(add_frameworks_dep kconfig)
  16. $(add_frameworks_dep kconfigwidgets)
  17. $(add_frameworks_dep kcoreaddons)
  18. $(add_frameworks_dep kcrash)
  19. $(add_frameworks_dep kdbusaddons)
  20. $(add_frameworks_dep kglobalaccel)
  21. $(add_frameworks_dep ki18n)
  22. $(add_frameworks_dep kiconthemes)
  23. $(add_frameworks_dep kio)
  24. $(add_frameworks_dep knewstuff)
  25. $(add_frameworks_dep knotifications)
  26. $(add_frameworks_dep knotifyconfig)
  27. $(add_frameworks_dep kparts)
  28. $(add_frameworks_dep kservice)
  29. $(add_frameworks_dep kwayland)
  30. $(add_frameworks_dep kwidgetsaddons)
  31. $(add_frameworks_dep kwindowsystem)
  32. $(add_frameworks_dep kxmlgui)
  33. $(add_kdeapps_dep konsole)
  34. $(add_qt_dep qtdbus)
  35. $(add_qt_dep qtgui)
  36. $(add_qt_dep qtwidgets)
  37. $(add_qt_dep qtx11extras)
  38. x11-libs/libX11
  39. "
  40. RDEPEND="${DEPEND}
  41. !kde-misc/yakuake:4
  42. "