lxdm-0.4.1-r9.ebuild 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. WANT_AUTOMAKE="1.12" #493996
  5. inherit eutils autotools systemd
  6. DESCRIPTION="LXDE Display Manager"
  7. HOMEPAGE="http://lxde.org"
  8. SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~arm ~ppc x86"
  12. IUSE="consolekit debug gtk3 nls pam"
  13. RDEPEND="consolekit? ( sys-auth/consolekit )
  14. x11-libs/libxcb
  15. gtk3? ( x11-libs/gtk+:3 )
  16. !gtk3? ( x11-libs/gtk+:2 )
  17. nls? ( sys-devel/gettext )
  18. pam? ( virtual/pam )"
  19. DEPEND="${RDEPEND}
  20. >=dev-util/intltool-0.40
  21. virtual/pkgconfig"
  22. src_prepare() {
  23. # Upstream bug, tarball contains pre-made lxdm.conf
  24. rm "${S}"/data/lxdm.conf || die
  25. # There is consolekit
  26. epatch "${FILESDIR}/${P}-pam_console-disable.patch"
  27. # Fix null pointer dereference, backported from git
  28. epatch "${FILESDIR}/${P}-git-fix-null-pointer-deref.patch"
  29. epatch "${FILESDIR}"/${P}-configure-add-pam.patch
  30. # 403999
  31. epatch "${FILESDIR}"/${P}-missing-pam-defines.patch
  32. # 412025
  33. epatch "${FILESDIR}"/${P}-event-check.patch
  34. # 393329 Selinux support
  35. epatch "${FILESDIR}"/${P}-selinux-support.patch
  36. # See https://bugs.launchpad.net/ubuntu/+source/lxdm/+bug/922363
  37. epatch "${FILESDIR}/${P}-fix-pam-100-cpu.patch"
  38. # Optional Consolekit support. bug #443666
  39. epatch "${FILESDIR}"/${P}-optional-consolekit.patch
  40. # 469512
  41. epatch "${FILESDIR}"/${P}-fix-optional-pam.patch
  42. # this replaces the bootstrap/autogen script in most packages
  43. eautoreconf
  44. # process LINGUAS
  45. if use nls; then
  46. einfo "Running intltoolize ..."
  47. intltoolize --force --copy --automake || die
  48. strip-linguas -i "${S}/po" || die
  49. fi
  50. }
  51. src_configure() {
  52. econf --enable-password \
  53. --with-x \
  54. --with-xconn=xcb \
  55. $(use_enable consolekit) \
  56. $(use_enable gtk3) \
  57. $(use_enable nls) \
  58. $(use_enable debug) \
  59. $(use_with pam)
  60. }
  61. src_install() {
  62. emake DESTDIR="${D}" install || die
  63. dodoc AUTHORS README TODO || die
  64. systemd_dounit "${FILESDIR}"/${PN}.service
  65. }
  66. pkg_postinst() {
  67. echo
  68. elog "Take into consideration that LXDM is in the early stages of development!"
  69. echo
  70. }