lxdm-0.5.3.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils autotools systemd
  5. DESCRIPTION="LXDE Display Manager"
  6. HOMEPAGE="http://lxde.org"
  7. SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~x86"
  11. IUSE="consolekit debug gtk3 nls pam"
  12. RDEPEND="consolekit? ( sys-auth/consolekit )
  13. x11-libs/libxcb
  14. gtk3? ( x11-libs/gtk+:3 )
  15. !gtk3? ( x11-libs/gtk+:2 )
  16. nls? ( sys-devel/gettext )
  17. pam? ( virtual/pam )"
  18. DEPEND="${RDEPEND}
  19. >=dev-util/intltool-0.40
  20. virtual/pkgconfig"
  21. DOCS=( AUTHORS README TODO )
  22. src_prepare() {
  23. # Upstream bug, tarball contains pre-made lxdm.conf
  24. rm "${S}"/data/lxdm.conf || die
  25. # Fix consolekit and selinux
  26. eapply "${FILESDIR}/${P}-pam_console-disable.patch"
  27. eapply_user
  28. # this replaces the bootstrap/autogen script in most packages
  29. eautoreconf
  30. # process LINGUAS
  31. if use nls; then
  32. einfo "Running intltoolize ..."
  33. intltoolize --force --copy --automake || die
  34. strip-linguas -i "${S}/po" || die
  35. fi
  36. }
  37. src_configure() {
  38. econf --enable-password \
  39. --with-x \
  40. --with-xconn=xcb \
  41. --with-systemdsystemunitdir=$(systemd_get_systemunitdir) \
  42. $(use_enable consolekit) \
  43. $(use_enable gtk3) \
  44. $(use_enable nls) \
  45. $(use_enable debug) \
  46. $(use_with pam)
  47. }
  48. src_install() {
  49. default_src_install
  50. #Use Gentoo specific Xsession startup file
  51. exeinto /etc/${PN}
  52. doexe "${FILESDIR}"/Xsession
  53. }