liblxqt-0.11.0-r1.ebuild 987 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="Common base library for the LXQt desktop environment"
  6. HOMEPAGE="http://lxqt.org/"
  7. if [[ ${PV} = *9999* ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
  10. else
  11. SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
  12. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  13. fi
  14. LICENSE="GPL-2 LGPL-2.1+"
  15. SLOT="0"
  16. RDEPEND=">=dev-libs/libqtxdg-1.3.0
  17. dev-qt/qtcore:5
  18. dev-qt/qtdbus:5
  19. dev-qt/qtgui:5
  20. dev-qt/qtwidgets:5
  21. dev-qt/qtx11extras:5
  22. dev-qt/qtxml:5
  23. kde-frameworks/kwindowsystem:5[X]
  24. x11-libs/libXScrnSaver"
  25. DEPEND="${RDEPEND}
  26. dev-qt/linguist-tools:5"
  27. pkg_pretend() {
  28. if [[ ${MERGE_TYPE} != binary ]]; then
  29. tc-is-gcc && [[ $(gcc-version) < 4.8 ]] && \
  30. die 'The active compiler needs to be gcc 4.8 (or newer)'
  31. fi
  32. }
  33. src_configure() {
  34. local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
  35. cmake-utils_src_configure
  36. }