cone-0.89.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils autotools
  5. DESCRIPTION="CONE: COnsole News reader and Emailer"
  6. HOMEPAGE="http://www.courier-mta.org/cone/"
  7. SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ~sparc x86"
  11. IUSE="crypt fam gnutls idn ipv6 ldap spell"
  12. RDEPEND=">=dev-libs/openssl-0.9.6
  13. dev-libs/libxml2
  14. sys-libs/ncurses
  15. crypt? ( >=app-crypt/gnupg-1.0.4 )
  16. fam? ( virtual/fam )
  17. gnutls? ( net-libs/gnutls )
  18. idn? ( net-dns/libidn )
  19. ipv6? ( net-dns/libidn )
  20. ldap? ( net-nds/openldap )
  21. spell? ( app-text/aspell )"
  22. DEPEND="${RDEPEND}
  23. dev-lang/perl"
  24. src_prepare() {
  25. epatch "${FILESDIR}"/${PN}-0.84.20100819-aspell-automagic.patch \
  26. "${FILESDIR}"/${PN}-0.86-skip-rfc2045-test.patch
  27. cd "${S}"/cone
  28. LIBTOOLIZE="true" eautoreconf
  29. cd "${S}"/rfc2045
  30. eautomake
  31. }
  32. src_configure() {
  33. local myconf
  34. if use spell ; then
  35. myconf="--with-spellcheck=aspell"
  36. else
  37. myconf="--with-spellcheck=none"
  38. fi
  39. econf \
  40. ${myconf} \
  41. $(use_with ldap ldapaddressbook) \
  42. $(use_with gnutls) \
  43. $(use_with idn libidn) \
  44. $(use_with ipv6)
  45. }
  46. src_install() {
  47. default
  48. emake DESTDIR="${D}" install-configure
  49. }