cone-0.90-r1.ebuild 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils autotools
  5. DESCRIPTION="CONE: COnsole News reader and Emailer"
  6. HOMEPAGE="http://www.courier-mta.org/cone/"
  7. SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ~sparc x86"
  11. IUSE="crypt fam gnutls idn ipv6 ldap spell"
  12. RDEPEND=">=dev-libs/openssl-0.9.6
  13. dev-libs/libxml2
  14. sys-libs/ncurses
  15. crypt? ( >=app-crypt/gnupg-1.0.4 )
  16. fam? ( virtual/fam )
  17. gnutls? ( net-libs/gnutls )
  18. idn? ( net-dns/libidn )
  19. ipv6? ( net-dns/libidn )
  20. ldap? ( net-nds/openldap )
  21. spell? ( app-text/aspell )"
  22. DEPEND="${RDEPEND}
  23. dev-lang/perl"
  24. src_prepare() {
  25. epatch "${FILESDIR}"/${PN}-0.84.20100819-aspell-automagic.patch
  26. epatch "${FILESDIR}"/${PN}-0.86-skip-rfc2045-test.patch
  27. epatch "${FILESDIR}"/${P}-gnutls3.patch
  28. # move local macro to m4 and run eautoreconf
  29. mkdir "${S}/m4"
  30. sed -n -e '/# AC_PROG_SYSCONFTOOL/,+33 p' "${S}"/aclocal.m4 > \
  31. m4/sysconftool.m4 || die
  32. sed -i -e '/^SUBDIRS/i ACLOCAL_AMFLAGS = -I m4' "${S}"/Makefile.am || die
  33. sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in */configure.in || die
  34. eautoreconf
  35. # TODO: Find and fix the bug - #514048
  36. cd cone && eautoreconf
  37. }
  38. src_configure() {
  39. local myconf
  40. if use spell ; then
  41. myconf="--with-spellcheck=aspell"
  42. else
  43. myconf="--with-spellcheck=none"
  44. fi
  45. econf \
  46. ${myconf} \
  47. $(use_with ldap ldapaddressbook) \
  48. $(use_with gnutls) \
  49. $(use_with idn libidn) \
  50. $(use_with ipv6)
  51. }
  52. src_install() {
  53. default
  54. emake DESTDIR="${D}" install-configure
  55. }