mailx-support-20060102-r1.ebuild 839 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="Provides lockspool utility"
  5. HOMEPAGE="http://www.openbsd.org/"
  6. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
  10. IUSE=""
  11. RDEPEND=""
  12. DEPEND=""
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. epatch "${FILESDIR}"/${P}-respect-ldflags.patch
  17. # This code should only be ran with Gentoo Prefix profiles
  18. if use prefix; then
  19. ebegin "Allowing unprivileged install"
  20. sed -i -e "s|-g 0 -o 0||g" Makefile
  21. eend $?
  22. fi
  23. }
  24. src_compile() {
  25. emake CC="$(tc-getCC)" BINDNOW_FLAGS="" || die "emake failed"
  26. }
  27. src_install() {
  28. einstall || die "einstall failed"
  29. }