mailx-support-20060102-r2.ebuild 875 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Provides lockspool utility"
  6. HOMEPAGE="http://www.openbsd.org/"
  7. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
  11. IUSE=""
  12. RDEPEND=""
  13. DEPEND=""
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-respect-ldflags.patch
  16. epatch "${FILESDIR}"/${P}-add-sys_file_h.patch
  17. # This code should only be ran with Gentoo Prefix profiles
  18. if use prefix; then
  19. ebegin "Allowing unprivileged install"
  20. sed -i -e "s|-g 0 -o 0||g" Makefile
  21. eend $?
  22. fi
  23. }
  24. src_compile() {
  25. emake CC="$(tc-getCC)" BINDNOW_FLAGS="" || die "emake failed"
  26. }
  27. src_install() {
  28. emake prefix="${ED}/usr" install
  29. }