roundcube-1.2.4.ebuild 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit webapp
  5. MY_PN=${PN}mail
  6. MY_P=${MY_PN}-${PV/_/-}
  7. DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
  8. HOMEPAGE="https://roundcube.net"
  9. SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${PV/_/-}/${MY_P}.tar.gz"
  10. # roundcube is GPL-licensed, the rest of the licenses here are
  11. # for bundled PEAR components, googiespell and utf8.class.php
  12. LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
  13. KEYWORDS="amd64 arm ~ppc ~ppc64 x86"
  14. IUSE="enigma ldap managesieve mysql postgres sqlite ssl spell"
  15. REQUIRED_USE="|| ( mysql postgres sqlite )"
  16. # this function only sets DEPEND so we need to include that in RDEPEND
  17. need_httpd_cgi
  18. RDEPEND="
  19. ${DEPEND}
  20. >=dev-lang/php-5.3.7[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,sqlite?,ssl?,unicode,xml]
  21. >=dev-php/PEAR-Auth_SASL-1.0.6
  22. >=dev-php/PEAR-Mail_Mime-1.8.9
  23. >=dev-php/PEAR-Mail_mimeDecode-1.5.5
  24. >=dev-php/PEAR-Net_IDNA2-0.1.1
  25. >=dev-php/PEAR-Net_SMTP-1.6.2
  26. virtual/httpd-php
  27. enigma? ( >=dev-php/PEAR-Crypt_GPG-1.4.0 app-crypt/gnupg )
  28. ldap? ( >=dev-php/PEAR-Net_LDAP2-2.0.12 dev-php/PEAR-Net_LDAP3 )
  29. managesieve? ( >=dev-php/PEAR-Net_Sieve-1.3.2 )
  30. mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
  31. spell? ( dev-lang/php[curl,spell] )
  32. "
  33. S=${WORKDIR}/${MY_P}
  34. src_install() {
  35. webapp_src_preinst
  36. dodoc CHANGELOG INSTALL README.md UPGRADING
  37. insinto "${MY_HTDOCSDIR}"
  38. doins -r [[:lower:]]* SQL
  39. doins .htaccess
  40. webapp_serverowned "${MY_HTDOCSDIR}"/logs
  41. webapp_serverowned "${MY_HTDOCSDIR}"/temp
  42. webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
  43. webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
  44. webapp_src_install
  45. }
  46. pkg_postinst() {
  47. webapp_pkg_postinst
  48. ewarn
  49. ewarn "When upgrading from <= 0.9, note that the old configuration files"
  50. ewarn "named main.inc.php and db.inc.php are deprecated and should be"
  51. ewarn "replaced with one single config.inc.php file."
  52. ewarn
  53. ewarn "Run the ./bin/update.sh script to convert those"
  54. ewarn "or manually merge the files."
  55. ewarn
  56. ewarn "The new config.inc.php should only contain options that"
  57. ewarn "differ from the ones listed in defaults.inc.php."
  58. ewarn
  59. }