mini-qmail-1.06.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. GENQMAIL_PV=20080406
  4. inherit eutils qmail
  5. DESCRIPTION="a small null client that forwards mail via QMQP to a full qmail server"
  6. HOMEPAGE="
  7. http://netqmail.org/
  8. http://cr.yp.to/qmail/mini.html
  9. http://qmail.org/
  10. "
  11. SRC_URI="mirror://qmail/netqmail-${PV}.tar.gz
  12. https://dev.gentoo.org/~hollow/distfiles/${GENQMAIL_F}"
  13. LICENSE="public-domain"
  14. SLOT="0"
  15. KEYWORDS="amd64 arm hppa ~mips ppc x86"
  16. IUSE=""
  17. DEPEND=""
  18. RDEPEND="
  19. !mail-mta/courier
  20. !mail-mta/esmtp
  21. !mail-mta/exim
  22. !mail-mta/maildrop
  23. !mail-mta/msmtp
  24. !mail-mta/netqmail
  25. !mail-mta/nullmailer
  26. !mail-mta/postfix
  27. !mail-mta/qmail-ldap
  28. !mail-mta/sendmail
  29. !mail-mta/ssmtp
  30. !mail-mta/opensmtpd
  31. ${DEPEND}
  32. "
  33. S="${WORKDIR}"/netqmail-${PV}
  34. src_unpack() {
  35. genqmail_src_unpack
  36. unpack netqmail-${PV}.tar.gz
  37. cd "${S}"
  38. epatch "${FILESDIR}"/${PV}-headers.patch
  39. qmail_src_postunpack
  40. }
  41. src_compile() {
  42. MAKEOPTS="${MAKEOPTS} -j1" qmail_src_compile #398135
  43. }
  44. # make check is actually an install-check target, see bug #364955
  45. src_test() { :; }
  46. qmail_base_install_hook() {
  47. dosym qmail-qmqpc "${QMAIL_HOME}"/bin/qmail-queue
  48. exeinto "${QMAIL_HOME}"/bin
  49. doexe "${FILESDIR}"/config-mini
  50. }
  51. src_install() {
  52. qmail_base_install
  53. qmail_man_install
  54. qmail_sendmail_install
  55. }