libmatekbd-1.16.0.ebuild 959 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MATE_LA_PUNT="yes"
  5. inherit mate
  6. if [[ ${PV} != 9999 ]]; then
  7. KEYWORDS="~amd64 ~arm ~x86"
  8. fi
  9. DESCRIPTION="MATE keyboard configuration library"
  10. LICENSE="LGPL-2"
  11. SLOT="0"
  12. IUSE="X gtk3 +introspection test"
  13. COMMON_DEPEND=">=dev-libs/glib-2.36:2
  14. x11-libs/cairo:0
  15. >=x11-libs/gdk-pixbuf-2.24:2
  16. x11-libs/libX11:0
  17. >=x11-libs/libxklavier-5.2:0[introspection?]
  18. x11-libs/pango:0
  19. virtual/libintl:0
  20. !gtk3? ( >=x11-libs/gtk+-2.24:2[introspection?] )
  21. gtk3? ( >=x11-libs/gtk+-3.0:3[introspection?] )
  22. introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
  23. RDEPEND="${COMMON_DEPEND}"
  24. DEPEND="${COMMON_DEPEND}
  25. sys-devel/gettext:*
  26. >=dev-util/intltool-0.50.1:*
  27. virtual/pkgconfig:*"
  28. src_configure() {
  29. mate_src_configure \
  30. --with-gtk=$(usex gtk3 3.0 2.0) \
  31. $(use_with X x) \
  32. $(use_enable introspection) \
  33. $(use_enable test tests)
  34. }