mate-desktop-1.16.1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MATE_LA_PUNT="yes"
  5. inherit mate
  6. if [[ ${PV} != 9999 ]]; then
  7. KEYWORDS="~amd64 ~arm ~x86"
  8. fi
  9. DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
  10. LICENSE="GPL-2 FDL-1.1 LGPL-2"
  11. SLOT="0"
  12. IUSE="X debug gtk3 +introspection startup-notification"
  13. COMMON_DEPEND="
  14. >=dev-libs/glib-2.36:2
  15. >=gnome-base/dconf-0.13.4:0
  16. x11-libs/cairo:0
  17. x11-libs/libX11:0
  18. >=x11-libs/libXrandr-1.3:0
  19. virtual/libintl:0
  20. !gtk3? ( >=x11-libs/gtk+-2.24:2[introspection?] )
  21. gtk3? ( >=x11-libs/gtk+-3.0:3[introspection?] )
  22. introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
  23. startup-notification? ( >=x11-libs/startup-notification-0.5:0 )"
  24. RDEPEND="${COMMON_DEPEND}"
  25. DEPEND="${COMMON_DEPEND}
  26. app-text/docbook-xml-dtd:4.1.2
  27. dev-util/gtk-doc
  28. dev-util/gtk-doc-am
  29. >=dev-util/intltool-0.40:*
  30. sys-devel/gettext:*
  31. >=x11-proto/randrproto-1.3:0
  32. x11-proto/xproto:0
  33. virtual/pkgconfig:*"
  34. src_configure() {
  35. mate_src_configure \
  36. --disable-mpaste \
  37. --enable-mate-about \
  38. --with-gtk=$(usex gtk3 3.0 2.0) \
  39. $(use_with X x) \
  40. $(use_enable debug) \
  41. $(use_enable introspection) \
  42. $(use_enable startup-notification)
  43. }