mate-polkit-1.16.0.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit mate
  5. if [[ ${PV} != 9999 ]]; then
  6. KEYWORDS="~amd64 ~arm ~x86"
  7. fi
  8. DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
  9. LICENSE="LGPL-2"
  10. SLOT="0"
  11. IUSE="accountsservice appindicator debug examples +introspection"
  12. COMMON_DEPEND=">=dev-libs/glib-2.36:2
  13. >=sys-auth/polkit-0.102:0[introspection?]
  14. x11-libs/gdk-pixbuf:2[introspection?]
  15. virtual/libintl:0
  16. >=x11-libs/gtk+-3.14.0:3[introspection?]
  17. appindicator? ( dev-libs/libappindicator:3 )
  18. introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )"
  19. RDEPEND="${COMMON_DEPEND}
  20. accountsservice? ( sys-apps/accountsservice:0[introspection?] )"
  21. DEPEND="${COMMON_DEPEND}
  22. dev-util/gtk-doc
  23. dev-util/gtk-doc-am
  24. >=dev-util/intltool-0.35:*
  25. sys-devel/gettext:*
  26. >=sys-devel/libtool-2.2.6
  27. virtual/pkgconfig:*
  28. !<gnome-extra/polkit-gnome-0.102:0"
  29. src_configure() {
  30. mate_src_configure \
  31. --disable-static \
  32. $(use_enable accountsservice) \
  33. $(use_enable appindicator) \
  34. $(use_enable debug) \
  35. $(use_enable examples) \
  36. $(use_enable introspection)
  37. }