SoXt-1.3.0.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils
  5. HOMEPAGE="http://www.coin3d.org/"
  6. DESCRIPTION="GUI binding for using Coin/Open Inventor with Xt/Motif"
  7. SRC_URI="https://bitbucket.org/Coin3D/coin/downloads/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
  10. SLOT="0"
  11. IUSE="debug doc static-libs"
  12. RDEPEND="
  13. >=media-libs/coin-3.1.3
  14. x11-libs/motif:0
  15. virtual/opengl"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig
  18. doc? ( app-doc/doxygen )"
  19. PATCHES=(
  20. "${FILESDIR}/${PN}-1.3.0-pkgconfig-partial.patch"
  21. )
  22. DOCS=(AUTHORS ChangeLog HACKING NEWS README TODO BUGS.txt)
  23. src_configure() {
  24. local myeconfargs=(
  25. htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
  26. --disable-compact
  27. --disable-html-help
  28. --includedir="$(coin-config --includedir)"
  29. --with-coin
  30. --with-motif
  31. $(use_enable debug)
  32. $(use_enable debug profile)
  33. $(use_enable doc html)
  34. $(use_enable doc man)
  35. )
  36. autotools-utils_src_configure
  37. # Remove SoXt from Libs.private (patch installs it in Libs)
  38. sed -i -e '/Libs.private/s/ -lSoXt//' "${BUILD_DIR}"/SoXt.pc || die
  39. # Strip the default libdir
  40. sed -i -e "s,-L%{_libdir} ,," soxt-default.cfg
  41. # soxt-config is arch dependent
  42. sed -i -e "s,/share/Coin/conf/,/%{_lib}/Coin2/conf/,g" soxt-config
  43. }