babl-9999.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. if [[ ${PV} == *9999* ]]; then
  6. inherit autotools git-r3
  7. EGIT_REPO_URI="git://git.gnome.org/babl"
  8. SRC_URI=""
  9. else
  10. SRC_URI="http://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
  11. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
  12. fi
  13. DESCRIPTION="A dynamic, any to any, pixel format conversion library"
  14. HOMEPAGE="http://www.gegl.org/babl/"
  15. LICENSE="LGPL-3"
  16. SLOT="0"
  17. IUSE="altivec cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_mmx"
  18. RDEPEND=""
  19. DEPEND="${RDEPEND}
  20. >=sys-devel/libtool-2.2
  21. virtual/pkgconfig
  22. "
  23. src_prepare() {
  24. default
  25. [[ ${PV} == *9999* ]] && eautoreconf
  26. }
  27. src_configure() {
  28. # Automagic rsvg support is just for website generation we do not call,
  29. # so we don't need to fix it
  30. # w3m is used for dist target thus no issue for us that it is automagically
  31. # detected
  32. econf \
  33. --disable-docs \
  34. --disable-static \
  35. --disable-maintainer-mode \
  36. $(use_enable altivec) \
  37. $(use_enable cpu_flags_x86_mmx mmx) \
  38. $(use_enable cpu_flags_x86_sse sse) \
  39. $(use_enable cpu_flags_x86_sse sse2)
  40. }
  41. src_install() {
  42. default
  43. prune_libtool_files --all
  44. }