exempi-2.2.1.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="Exempi is a port of the Adobe XMP SDK to work on UNIX"
  6. HOMEPAGE="https://libopenraw.freedesktop.org/wiki/Exempi"
  7. SRC_URI="https://libopenraw.freedesktop.org/download/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="2"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
  11. IUSE="examples static-libs"
  12. RDEPEND=">=dev-libs/expat-2:=
  13. virtual/libiconv
  14. sys-libs/zlib:="
  15. DEPEND="${RDEPEND}
  16. sys-devel/gettext"
  17. RESTRICT="test" #295875
  18. DOCS="AUTHORS ChangeLog NEWS README TODO"
  19. src_prepare() {
  20. epatch "${FILESDIR}"/${PN}-2.1.1-iconv.patch
  21. cp /usr/share/gettext/config.rpath . || die
  22. eautoreconf
  23. }
  24. src_configure() {
  25. econf \
  26. $(use_enable static-libs static) \
  27. --disable-unittest
  28. }
  29. src_install() {
  30. default
  31. prune_libtool_files --all
  32. if use examples; then
  33. emake -C samples/source distclean
  34. rm -f samples/{,source,testfiles}/Makefile*
  35. insinto /usr/share/doc/${PF}/examples
  36. doins -r samples/*
  37. fi
  38. }