faac-1.28-r4.ebuild 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils multilib-minimal
  5. DESCRIPTION="Free MPEG-4 audio codecs by AudioCoding.com"
  6. HOMEPAGE="http://www.audiocoding.com"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="LGPL-2.1 MPEG-4"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
  11. IUSE="static-libs"
  12. RDEPEND="media-libs/libmp4v2:0=
  13. abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r1
  14. !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
  15. DEPEND="${RDEPEND}"
  16. DOCS=( AUTHORS ChangeLog NEWS README TODO )
  17. src_prepare() {
  18. epatch \
  19. "${FILESDIR}"/${P}-external-libmp4v2.patch \
  20. "${FILESDIR}"/${P}-altivec.patch \
  21. "${FILESDIR}"/${P}-libmp4v2_r479_compat.patch \
  22. "${FILESDIR}"/${P}-inttypes.patch
  23. sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die #466984
  24. eautoreconf
  25. epunt_cxx
  26. }
  27. multilib_src_configure() {
  28. local myconf
  29. # only used for the fronted we need only for the default ABI.
  30. [ "${ABI}" != "${DEFAULT_ABI}" ] && myconf+=" --without-mp4v2"
  31. ECONF_SOURCE="${S}" econf \
  32. $(use_enable static-libs static) \
  33. ${myconf}
  34. # do not build the frontend for non default abis
  35. if [ "${ABI}" != "${DEFAULT_ABI}" ] ; then
  36. sed -i -e 's/frontend//' Makefile || die
  37. fi
  38. }
  39. multilib_src_install() {
  40. emake DESTDIR="${D}" install
  41. prune_libtool_files
  42. }
  43. multilib_src_install_all() {
  44. einstalldocs
  45. dohtml docs/*.html
  46. insinto /usr/share/doc/${PF}/pdf
  47. doins docs/libfaac.pdf
  48. }