ffmpegsource-2.23.ebuild 940 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils flag-o-matic vcs-snapshot
  5. DESCRIPTION="A libav/ffmpeg based source library for easy frame accurate access"
  6. HOMEPAGE="https://github.com/FFMS/ffms2"
  7. SRC_URI="https://github.com/FFMS/ffms2/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0/4"
  10. KEYWORDS="amd64 x86"
  11. IUSE="libav"
  12. RDEPEND="
  13. sys-libs/zlib
  14. !libav? ( >=media-video/ffmpeg-2.4:0= )
  15. libav? ( >=media-video/libav-9:0= )
  16. "
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig
  19. "
  20. ffms_check_compiler() {
  21. if [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++11; then
  22. die "Your compiler lacks C++11 support. Use GCC>=4.7.0 or Clang>=3.3."
  23. fi
  24. }
  25. pkg_pretend() {
  26. ffms_check_compiler
  27. }
  28. pkg_setup() {
  29. ffms_check_compiler
  30. }
  31. src_prepare() {
  32. default_src_prepare
  33. eautoreconf
  34. }
  35. src_install() {
  36. default_src_install
  37. prune_libtool_files
  38. }