glu-9.0.0-r1.ebuild 994 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/glu"
  5. if [[ ${PV} = 9999* ]]; then
  6. AUTOTOOLS_AUTORECONF=1
  7. GIT_ECLASS="git-2"
  8. EXPERIMENTAL="true"
  9. fi
  10. inherit autotools-multilib multilib ${GIT_ECLASS}
  11. DESCRIPTION="The OpenGL Utility Library"
  12. HOMEPAGE="https://cgit.freedesktop.org/mesa/glu/"
  13. if [[ ${PV} = 9999* ]]; then
  14. SRC_URI=""
  15. else
  16. SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/${PN}/${P}.tar.bz2"
  17. fi
  18. LICENSE="SGI-B-2.0"
  19. SLOT="0"
  20. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
  21. IUSE="static-libs"
  22. DEPEND=">=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]"
  23. RDEPEND="${DEPEND}
  24. !<media-libs/mesa-9
  25. abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
  26. src_unpack() {
  27. default
  28. [[ $PV = 9999* ]] && git-2_src_unpack
  29. }
  30. src_test() {
  31. :;
  32. }