grilo-0.2.15.ebuild 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
  5. GNOME2_LA_PUNT="yes"
  6. PYTHON_COMPAT=( python2_7 )
  7. VALA_MIN_API_VERSION="0.28"
  8. VALA_USE_DEPEND="vapigen"
  9. inherit gnome2 python-any-r1 vala
  10. DESCRIPTION="A framework for easy media discovery and browsing"
  11. HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
  12. LICENSE="LGPL-2.1+"
  13. SLOT="0.2/1" # subslot is libgrilo-0.2 soname suffix
  14. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
  15. IUSE="gtk examples +introspection +network playlist test vala"
  16. REQUIRED_USE="test? ( introspection )"
  17. RDEPEND="
  18. >=dev-libs/glib-2.44:2
  19. dev-libs/libxml2:2
  20. net-libs/liboauth
  21. gtk? ( >=x11-libs/gtk+-3:3 )
  22. introspection? ( >=dev-libs/gobject-introspection-0.9:= )
  23. network? ( >=net-libs/libsoup-2.41.3:2.4 )
  24. playlist? ( >=dev-libs/totem-pl-parser-3.4.1 )
  25. "
  26. DEPEND="${RDEPEND}
  27. >=dev-util/gtk-doc-am-1.10
  28. >=dev-util/intltool-0.40
  29. virtual/pkgconfig
  30. vala? ( $(vala_depend) )
  31. test? (
  32. $(python_gen_any_dep '
  33. dev-python/pygobject:2[${PYTHON_USEDEP}]
  34. dev-python/pygobject:3[${PYTHON_USEDEP}]')
  35. media-plugins/grilo-plugins:0.2 )
  36. "
  37. # eautoreconf requires gnome-common
  38. python_check_deps() {
  39. has_version "dev-python/pygobject:2[${PYTHON_USEDEP}]" && \
  40. has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
  41. }
  42. pkg_setup() {
  43. use test && python-any-r1_pkg_setup
  44. }
  45. src_prepare() {
  46. # Don't build examples
  47. sed -e '/SUBDIRS/s/examples//' \
  48. -i Makefile.am -i Makefile.in || die
  49. use vala && vala_src_prepare
  50. gnome2_src_prepare
  51. }
  52. src_configure() {
  53. # --enable-debug only changes CFLAGS, useless for us
  54. gnome2_src_configure \
  55. --disable-static \
  56. --disable-debug \
  57. $(use_enable gtk test-ui) \
  58. $(use_enable introspection) \
  59. $(use_enable network grl-net) \
  60. $(use_enable playlist grl-pls) \
  61. $(use_enable test tests) \
  62. $(use_enable vala)
  63. }
  64. src_install() {
  65. gnome2_src_install
  66. # Upstream made this conditional on gtk-doc build...
  67. emake -C doc install DESTDIR="${ED}"
  68. if use examples; then
  69. # Install example code
  70. insinto /usr/share/doc/${PF}/examples
  71. doins "${S}"/examples/*.c
  72. fi
  73. }