gst-plugins-base-1.10.3.ebuild 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GST_ORG_MODULE="gst-plugins-base"
  5. inherit gstreamer
  6. DESCRIPTION="Basepack of plugins for gstreamer"
  7. HOMEPAGE="https://gstreamer.freedesktop.org/"
  8. LICENSE="GPL-2+ LGPL-2+"
  9. KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  10. IUSE="alsa +introspection ivorbis +ogg +orc +pango theora +vorbis X"
  11. REQUIRED_USE="
  12. ivorbis? ( ogg )
  13. theora? ( ogg )
  14. vorbis? ( ogg )
  15. "
  16. RDEPEND="
  17. app-text/iso-codes
  18. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  19. >=media-libs/gstreamer-${PV}:1.0[introspection?,${MULTILIB_USEDEP}]
  20. >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
  21. alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
  22. introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
  23. ivorbis? ( >=media-libs/tremor-0_pre20130223[${MULTILIB_USEDEP}] )
  24. ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )
  25. orc? ( >=dev-lang/orc-0.4.24[${MULTILIB_USEDEP}] )
  26. pango? ( >=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}] )
  27. theora? ( >=media-libs/libtheora-1.1.1[encode,${MULTILIB_USEDEP}] )
  28. vorbis? ( >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}] )
  29. X? (
  30. >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
  31. >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
  32. >=x11-libs/libXv-1.0.10[${MULTILIB_USEDEP}] )
  33. "
  34. DEPEND="${RDEPEND}
  35. >=dev-util/gtk-doc-am-1.12
  36. X? (
  37. >=x11-proto/videoproto-2.3.1-r1[${MULTILIB_USEDEP}]
  38. >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
  39. >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )
  40. "
  41. multilib_src_configure() {
  42. gstreamer_multilib_src_configure \
  43. $(use_enable alsa) \
  44. $(multilib_native_use_enable introspection) \
  45. $(use_enable ivorbis) \
  46. $(use_enable ogg) \
  47. $(use_enable orc) \
  48. $(use_enable pango) \
  49. $(use_enable theora) \
  50. $(use_enable vorbis) \
  51. $(use_enable X x) \
  52. $(use_enable X xshm) \
  53. $(use_enable X xvideo) \
  54. --disable-debug \
  55. --disable-examples \
  56. --disable-static
  57. # cdparanoia and libvisual are split out, per leio's request
  58. # bug #366931, flag-o-matic for the whole thing is overkill
  59. if [[ ${CHOST} == *86-*-darwin* ]] ; then
  60. sed -i \
  61. -e '/FLAGS = /s|-O[23]|-O1|g' \
  62. gst/audioconvert/Makefile \
  63. gst/volume/Makefile || die
  64. fi
  65. if multilib_is_native_abi; then
  66. local x
  67. for x in libs plugins; do
  68. ln -s "${S}"/docs/${x}/html docs/${x}/html || die
  69. done
  70. fi
  71. }
  72. multilib_src_install_all() {
  73. DOCS="AUTHORS NEWS README RELEASE"
  74. einstalldocs
  75. prune_libtool_files --modules
  76. }