hal-flash-0.3.3.ebuild 745 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils
  5. DESCRIPTION="A libhal stub library forwarding to UDisks for www-plugins/adobe-flash to play DRM content"
  6. HOMEPAGE="https://github.com/cshorler/hal-flash http://build.opensuse.org/package/show/devel:openSUSE:Factory/hal-flash"
  7. SRC_URI="http://github.com/cshorler/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. COMMON_DEPEND="sys-apps/dbus
  13. !sys-apps/hal"
  14. RDEPEND="${COMMON_DEPEND}
  15. sys-fs/udisks"
  16. DEPEND="${COMMON_DEPEND}
  17. virtual/pkgconfig"
  18. DOCS="README"
  19. src_prepare() {
  20. eautoreconf; eapply_user;
  21. }
  22. src_install() {
  23. default
  24. prune_libtool_files
  25. }