imlib-1.9.15-r4.ebuild 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils multilib-minimal
  5. PVP=(${PV//[-\._]/ })
  6. DESCRIPTION="Image loading and rendering library"
  7. HOMEPAGE="http://ftp.acc.umu.se/pub/GNOME/sources/imlib/1.9/"
  8. SRC_URI="mirror://gnome/sources/${PN}/${PVP[0]}.${PVP[1]}/${P}.tar.bz2
  9. mirror://gentoo/gtk-1-for-imlib.m4.bz2"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd"
  13. IUSE="doc static-libs"
  14. RDEPEND=">=media-libs/tiff-3.9.7-r1[${MULTILIB_USEDEP}]
  15. >=media-libs/giflib-4.1.6-r3[${MULTILIB_USEDEP}]
  16. >=media-libs/libpng-1.2.51[${MULTILIB_USEDEP}]
  17. >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}]
  18. >=x11-libs/libICE-1.0.8-r1[${MULTILIB_USEDEP}]
  19. >=x11-libs/libSM-1.2.1-r1[${MULTILIB_USEDEP}]
  20. >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
  21. abi_x86_32? (
  22. !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
  23. !<=app-emulation/emul-linux-x86-gtklibs-20140406
  24. )"
  25. DEPEND="${RDEPEND}"
  26. src_prepare() {
  27. # Fix aclocal underquoted definition warnings.
  28. # Conditionalize gdk functions for bug 40453.
  29. # Fix imlib-config for bug 3425.
  30. epatch "${FILESDIR}"/${P}.patch
  31. epatch "${FILESDIR}"/${PN}-security.patch #security #72681
  32. epatch "${FILESDIR}"/${P}-bpp16-CVE-2007-3568.patch # security #201887
  33. epatch "${FILESDIR}"/${P}-fix-rendering.patch #197489
  34. epatch "${FILESDIR}"/${P}-asneeded.patch #207638
  35. epatch "${FILESDIR}"/${P}-libpng15.patch #357167
  36. epatch "${FILESDIR}"/${P}-underlinking-test.patch #367645
  37. epatch "${FILESDIR}"/${P}-no-LDFLAGS-in-pc.patch
  38. mkdir m4 && cp "${WORKDIR}"/gtk-1-for-imlib.m4 m4
  39. AT_M4DIR="m4" eautoreconf
  40. }
  41. multilib_src_configure() {
  42. ECONF_SOURCE="${S}" econf \
  43. --sysconfdir=/etc/imlib \
  44. $(use_enable static-libs static) \
  45. --disable-gdk \
  46. --disable-gtktest
  47. }
  48. multilib_src_install() {
  49. emake DESTDIR="${D}" install || die
  50. }
  51. multilib_src_install_all() {
  52. dodoc AUTHORS ChangeLog README
  53. use doc && dohtml doc/*
  54. # Punt unused files
  55. rm -f "${D}"/usr/lib*/pkgconfig/imlibgdk.pc
  56. find "${D}" -name '*.la' -exec rm -f {} +
  57. }