libXcm-0.5.2-r1.ebuild 774 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-multilib
  5. DESCRIPTION="reference implementation of the net-color spec"
  6. HOMEPAGE="http://www.oyranos.org/libxcm/"
  7. SRC_URI="mirror://sourceforge/oyranos/${PN}/${PN}-0.4.x/${P}.tar.bz2"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE="X static-libs"
  12. RDEPEND="X? ( >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
  13. >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
  14. >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
  15. >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )"
  16. DEPEND="${RDEPEND}"
  17. src_configure() {
  18. local myeconfargs=(
  19. --disable-silent-rules
  20. $(use_with X x11)
  21. $(use_enable static-libs static)
  22. )
  23. autotools-multilib_src_configure
  24. }