libbdplus-9999.ebuild 843 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-multilib
  5. if [[ ${PV} == 9999 ]] ; then
  6. inherit git-r3
  7. EGIT_REPO_URI="git://git.videolan.org/${PN}.git"
  8. else
  9. SRC_URI="http://ftp.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
  10. KEYWORDS="~amd64 ~x86"
  11. fi
  12. DESCRIPTION="Blu-ray library for BD+ decryption"
  13. HOMEPAGE="http://www.videolan.org/developers/libbdplus.html"
  14. LICENSE="LGPL-2.1"
  15. SLOT="0"
  16. IUSE="aacs static-libs"
  17. RDEPEND="dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
  18. dev-libs/libgpg-error[${MULTILIB_USEDEP}]
  19. aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )"
  20. DEPEND="${RDEPEND}"
  21. DOCS="ChangeLog README.txt"
  22. src_configure() {
  23. local myeconfargs=(
  24. --disable-optimizations
  25. $(use_with aacs libaacs)
  26. )
  27. autotools-multilib_src_configure
  28. }