libcdr-0.0.14.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
  5. inherit base eutils
  6. [[ ${PV} == 9999 ]] && inherit autotools git-2
  7. DESCRIPTION="Library parsing the Corel cdr documents"
  8. HOMEPAGE="https://www.freedesktop.org/wiki/Software/libcdr"
  9. [[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
  10. LICENSE="LGPL-2.1"
  11. SLOT="0"
  12. [[ ${PV} == 9999 ]] || \
  13. KEYWORDS="amd64 ~arm ppc x86"
  14. IUSE="doc static-libs"
  15. RDEPEND="
  16. app-text/libwpd:0.9
  17. app-text/libwpg:0.2
  18. dev-libs/icu:=
  19. media-libs/lcms:2
  20. sys-libs/zlib
  21. "
  22. DEPEND="${RDEPEND}
  23. dev-libs/boost
  24. sys-devel/libtool
  25. virtual/pkgconfig
  26. doc? ( app-doc/doxygen )
  27. "
  28. src_prepare() {
  29. base_src_prepare
  30. [[ -d m4 ]] || mkdir "m4"
  31. [[ ${PV} == 9999 ]] && eautoreconf
  32. }
  33. src_configure() {
  34. econf \
  35. --docdir="${EPREFIX}/usr/share/doc/${PF}" \
  36. $(use_enable static-libs static) \
  37. --disable-werror \
  38. $(use_with doc docs)
  39. }
  40. src_install() {
  41. default
  42. prune_libtool_files --all
  43. }