libdvdnav-5.0.3.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=1
  5. AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
  6. inherit autotools-multilib
  7. DESCRIPTION="Library for DVD navigation tools"
  8. HOMEPAGE="http://dvdnav.mplayerhq.hu/"
  9. if [[ ${PV} = 9999 ]]; then
  10. inherit git-r3
  11. EGIT_REPO_URI="git://git.videolan.org/libdvdnav.git"
  12. KEYWORDS="alpha arm hppa ia64 ppc ppc64 sparc"
  13. else
  14. SRC_URI="http://downloads.videolan.org/pub/videolan/libdvdnav/${PV}/${P}.tar.bz2"
  15. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
  16. fi
  17. LICENSE="GPL-2"
  18. SLOT="0"
  19. IUSE="static-libs"
  20. RDEPEND=">=media-libs/libdvdread-5.0.2[${MULTILIB_USEDEP}]
  21. abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r4
  22. !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
  23. DEPEND="${RDEPEND}
  24. virtual/pkgconfig" # To get pkg.m4 for eautoreconf #414391
  25. DOCS=( AUTHORS ChangeLog doc/dvd_structures doc/library_layout README TODO )