libgii-1.0.2-r1.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=1
  5. inherit autotools-multilib
  6. DESCRIPTION="Fast and safe graphics and drivers for about any graphics card to the Linux kernel (sometimes)"
  7. HOMEPAGE="http://www.ggi-project.org"
  8. SRC_URI="mirror://sourceforge/ggi/${P}.src.tar.bz2"
  9. LICENSE="LGPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
  12. IUSE="X"
  13. RDEPEND="X? (
  14. >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
  15. >=x11-libs/libXxf86dga-1.1.4[${MULTILIB_USEDEP}]
  16. )"
  17. DEPEND="${RDEPEND}
  18. kernel_linux? ( >=sys-kernel/linux-headers-2.6.11 )"
  19. PATCHES=(
  20. "${FILESDIR}"/${PN}-0.9.0-linux26-headers.patch
  21. "${FILESDIR}"/${P}-configure-cpuid-pic.patch
  22. "${FILESDIR}"/${P}-libtool_1.5_compat.patch
  23. )
  24. DOCS=( ChangeLog ChangeLog.1999 FAQ NEWS README )
  25. MULTILIB_WRAPPED_HEADERS=( /usr/include/ggi/system.h )
  26. src_prepare() {
  27. rm -f acinclude.m4 m4/libtool.m4 m4/lt*.m4
  28. AT_M4DIR=m4 autotools-multilib_src_prepare
  29. }
  30. src_configure() {
  31. local myeconfargs=( $(use_with X x) $(use_enable X x) )
  32. autotools-multilib_src_configure
  33. }