libgpod-0.8.3-r2.ebuild 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit autotools eutils mono-env python-single-r1 udev
  6. DESCRIPTION="Shared library to access the contents of an iPod"
  7. HOMEPAGE="http://www.gtkpod.org/libgpod/"
  8. SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.bz2"
  9. LICENSE="LGPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="+gtk python +udev ios mono static-libs"
  13. REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
  14. RDEPEND="
  15. >=app-pda/libplist-1.0:=
  16. >=dev-db/sqlite-3:3
  17. >=dev-libs/glib-2.16:2
  18. dev-libs/libxml2:2
  19. sys-apps/sg3_utils
  20. gtk? ( x11-libs/gdk-pixbuf:2 )
  21. ios? ( app-pda/libimobiledevice:= )
  22. python? (
  23. ${PYTHON_DEPS}
  24. >=media-libs/mutagen-1.8[${PYTHON_USEDEP}]
  25. >=dev-python/pygobject-2.8:2[${PYTHON_USEDEP}]
  26. )
  27. udev? ( virtual/udev )
  28. mono? (
  29. >=dev-lang/mono-1.9.1
  30. >=dev-dotnet/gtk-sharp-2.12
  31. )
  32. "
  33. DEPEND="${RDEPEND}
  34. python? ( >=dev-lang/swig-1.3.24:0 )
  35. dev-libs/libxslt
  36. dev-util/intltool
  37. dev-util/gtk-doc-am
  38. sys-devel/gettext
  39. virtual/pkgconfig
  40. "
  41. DOCS="AUTHORS NEWS README* TROUBLESHOOTING"
  42. PATCHES=(
  43. "${FILESDIR}"/${P}-comment.patch #537968
  44. "${FILESDIR}"/${P}-segfault.patch #565052
  45. "${FILESDIR}"/${P}-mono4.patch
  46. "${FILESDIR}"/${P}-pkgconfig_overlinking.patch
  47. )
  48. pkg_setup() {
  49. use mono && mono-env_pkg_setup
  50. use python && python-single-r1_pkg_setup
  51. }
  52. src_prepare() {
  53. default
  54. # mono-4 fixes from Fedora
  55. sed -i "s#public DateTime#public System.DateTime#g" bindings/mono/libgpod-sharp/Artwork.cs || die
  56. eautoreconf
  57. }
  58. src_configure() {
  59. econf \
  60. $(use_enable static-libs static) \
  61. $(use_enable udev) \
  62. $(use_enable gtk gdk-pixbuf) \
  63. $(use_enable python pygobject) \
  64. --without-hal \
  65. $(use_with ios libimobiledevice) \
  66. --with-udev-dir="$(get_udevdir)" \
  67. $(use_with python) \
  68. $(use_with mono)
  69. }
  70. src_install() {
  71. default
  72. rmdir "${ED}"/tmp
  73. prune_libtool_files --modules
  74. }