liblrdf-0.5.0-r1.ebuild 1015 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools
  5. DESCRIPTION="A library for the manipulation of RDF file in LADSPA plugins"
  6. HOMEPAGE="https://github.com/swh/LRDF"
  7. SRC_URI="https://github.com/swh/LRDF/tarball/${PV} -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
  11. IUSE="libressl static-libs"
  12. RDEPEND="
  13. !libressl? ( >=dev-libs/openssl-1:0= )
  14. libressl? ( dev-libs/libressl )
  15. media-libs/raptor:2
  16. >=media-libs/ladspa-sdk-1.12"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig"
  19. DOCS=( AUTHORS ChangeLog README )
  20. src_unpack() {
  21. unpack ${A}
  22. mv *-LRDF-* "${S}"
  23. }
  24. src_prepare() {
  25. sed -i -e 's:usr/local:usr:' examples/{instances,remove}_test.c || die #392221
  26. eautoreconf
  27. }
  28. src_configure() {
  29. econf $(use_enable static-libs static)
  30. }
  31. src_test() {
  32. has_version media-plugins/swh-plugins && default #392221
  33. }
  34. src_install() {
  35. default
  36. rm -f "${ED}"usr/lib*/liblrdf.la
  37. }