libmpris2client-0.1.0.ebuild 706 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils gnome2-utils
  5. DESCRIPTION="An library to control MPRIS2 compatible players"
  6. HOMEPAGE="https://github.com/matiasdelellis/libmpris2client"
  7. SRC_URI="https://github.com/matiasdelellis/${PN}/releases/download/V${PV}/${P}.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND=">=dev-libs/glib-2
  13. x11-libs/gtk+:2"
  14. DEPEND="${RDEPEND}
  15. virtual/pkgconfig"
  16. DOCS="AUTHORS NEWS README TODO"
  17. src_install() {
  18. default
  19. prune_libtool_files
  20. }
  21. pkg_preinst() { gnome2_icon_savelist; }
  22. pkg_postinst() { gnome2_icon_cache_update; }
  23. pkg_postrm() { gnome2_icon_cache_update; }