libpagemaker-0.0.3-r1.ebuild 950 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. EGIT_REPO_URI="git://gerrit.libreoffice.org/${PN}.git"
  5. [[ ${PV} == 9999 ]] && inherit autotools git-r3
  6. DESCRIPTION="C++ Library that parses the file format of Aldus/Adobe PageMaker documents."
  7. HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
  8. [[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
  9. LICENSE="MPL-2.0"
  10. SLOT="0"
  11. [[ ${PV} == 9999 ]] || \
  12. KEYWORDS="amd64 ~arm ~hppa ~ppc64 x86 ~amd64-linux ~x86-linux"
  13. IUSE="debug doc tools"
  14. RDEPEND="
  15. dev-libs/librevenge
  16. "
  17. DEPEND="${RDEPEND}
  18. dev-libs/boost
  19. virtual/pkgconfig
  20. doc? ( app-doc/doxygen )
  21. "
  22. src_prepare() {
  23. default
  24. [[ ${PV} == 9999 ]] && eautoreconf
  25. }
  26. src_configure() {
  27. econf \
  28. --disable-werror \
  29. $(use_with doc docs) \
  30. $(use_enable tools)
  31. }
  32. src_install() {
  33. default
  34. find "${D}" -name '*.la' -delete || die
  35. }