libquvi-scripts-0.4.19.ebuild 575 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Embedded lua scripts for libquvi"
  5. HOMEPAGE="http://quvi.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/quvi/${PV:0:3}/${P}.tar.xz"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  10. IUSE="offensive"
  11. DEPEND="app-arch/xz-utils"
  12. # tests fetch data from live websites, so it's rather normal that they
  13. # will fail
  14. RESTRICT="test"
  15. src_configure() {
  16. econf \
  17. --with-manual \
  18. $(use_with offensive nsfw)
  19. }