libquvi-scripts-0.4.21-r1.ebuild 623 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Embedded lua scripts for libquvi"
  5. HOMEPAGE="http://quvi.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/quvi/${PV:0:3}/${P}.tar.xz"
  7. LICENSE="GPL-3"
  8. SLOT="0.4"
  9. KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
  10. IUSE="offensive"
  11. DEPEND="app-arch/xz-utils"
  12. RDEPEND="!=media-libs/libquvi-scripts-0.4*:0"
  13. # tests fetch data from live websites, so it's rather normal that they
  14. # will fail
  15. RESTRICT="test"
  16. src_configure() {
  17. econf \
  18. --without-manual \
  19. $(use_with offensive nsfw)
  20. }