libquvi-scripts-0.4.21-r2.ebuild 674 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit multilib-minimal
  5. DESCRIPTION="Embedded lua scripts for libquvi"
  6. HOMEPAGE="http://quvi.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/quvi/${PV:0:3}/${P}.tar.xz"
  8. LICENSE="GPL-3"
  9. SLOT="0.4"
  10. KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
  11. IUSE="offensive"
  12. DEPEND="app-arch/xz-utils"
  13. RDEPEND="!=media-libs/libquvi-scripts-0.4*:0"
  14. # tests fetch data from live websites, so it's rather normal that they
  15. # will fail
  16. RESTRICT="test"
  17. multilib_src_configure() {
  18. ECONF_SOURCE=${S} \
  19. econf \
  20. --without-manual \
  21. $(use_with offensive nsfw)
  22. }